VSPE und MixW

Antworten
dl1dwl
Normaler Benutzer
Beiträge: 7
Registriert: Sa 15. Jul 2006, 21:41

VSPE und MixW

Beitrag von dl1dwl »

Ich brauche Hilfe für nachfolgendes Problem.
Ich benutze MixW für die Steuerung des Transceivers TS-870 mit USB-Interface und integrierter Soundkarte. Dieses System läuft über den COM-Port 8.
Ein separates Steuerprogramm für die Magnetantenne benötigt die Frequenzdaten des TRCV und müßte auf die Daten von COM-Port 8 zugreifen dürfen. Das Betriebssystem verweigert den Zugriff,weil der Port nur von einem Programm gleichzeitig genutzt werden kann.
Abhilfe soll VSPE von Eterlogic bringen, welches einen virtuellen COM-Port generiert. (siehe hierzu FA8/09 S.852)
Leider funktioniert diese Anwendung des Splitters COM8 zu COM3 bei mir nicht.
Entweder zeigt MixW an, daß der COM-Port 8 bereits von einem anderen Programm belegt ist.( wenn VSPE aktiv ist)
Oder wenn COM-Port 8 bei MixW aktiv ist und VSPE den COM 8 auf den vitualen COM 3 splitten soll , dann kommt die Anzeige Initialization Error(0)
Wer kann helfen und mir sagen was ich falsch mache. Für jeden Hinweis bin ich dankbar.
73 de DL1DWL
dm5hs

Beitrag von dm5hs »

Hallo,

kannst nicht den COM Port deines USB-Interface auf einen anderen Port umbiegen? und dann deinen virtuellen COM 8 erstellen


73, Sebastian
dm6dx
Normaler Benutzer
Beiträge: 314
Registriert: So 18. Feb 2007, 16:22
Wohnort: Berlin

Beitrag von dm6dx »

Hallo Manfred,
die CAT-Interface bringen die Virtuellen COM-Tools bereits mit.
Wenn du uns sagt, was du hast, dann kann dir geholfen werden.
Wenn du MixW unter RigExpert benutzt gibt es die Möglichkeit mit REFTDI die Ports zu bestimmen.
Unter microHAM kannst du das in der Menüleiste des Device routers machen.
Welches Interface benutzt du? Wenn es die o.g. sind können wir das alles durchspielen.

73 de Robby
DM6DX
dj7ww

Re: VSPE und MixW

Beitrag von dj7ww »

dl1dwl hat geschrieben:Ich brauche Hilfe für nachfolgendes Problem.
Ich benutze MixW für die Steuerung des Transceivers TS-870 mit USB-Interface und integrierter Soundkarte. Dieses System läuft über den COM-Port 8.

Das kannst Du auch auf einen anderen Port legen.
COM 8 ist sowieso nur ein virtueller Port.


Ein separates Steuerprogramm für die Magnetantenne benötigt die Frequenzdaten des TRCV und müßte auf die Daten von COM-Port 8 zugreifen dürfen. Das Betriebssystem verweigert den Zugriff,weil der Port nur von einem Programm gleichzeitig genutzt werden kann.
Das ist normal, dass auf einen bereits belegten Port nicht zugegriffen werden kann.
Pro Anwendung musst Du einen eigenen Port generieren.
Mit DDUtil ist es soweit ich weiss jedoch möglich Leseinformation vom gleichen Port weiter zu reichen.

73
Peter
dl1dwl
Normaler Benutzer
Beiträge: 7
Registriert: Sa 15. Jul 2006, 21:41

Beitrag von dl1dwl »

Hallo Robby,
vielen Dank und auch den anderen Om's für ihre Nachricht.
Ich betreibe TS-870 mit USB/CAT-Interface ONE vom FA-Leserservice.
Der Antennenschrittmotor wird ebenfalls über ein USB-Interface gesteuert.
Die Steuersoftware benötigt zum Arbeiten die Frequenzdaten vom TS-870.
Es funktioniert wenn entweder die Steuersoftware oder MixW auf den Port 8 zugreifen. Deshalb habe ich versucht mit VSPE den Port zu splitten.
Ich hoffe,dass die kurze Erklärung mein Problem beschreibt.

73 de Manfred
DL1DWL
dm6dx
Normaler Benutzer
Beiträge: 314
Registriert: So 18. Feb 2007, 16:22
Wohnort: Berlin

Beitrag von dm6dx »

Hallo Manfred,
das Interface stellt einen Ser-USB Port zur verfügung. Diesen kannst du im Gerätemanager ändern.
Lies dir mal die Doku vom FA durch, auf Seite 9 steht was du suchst.....
http://www.box73.de/download/bausaetze/BX-120.pdf

...so sollte es gehen.

73 de Robby
dl1dwl
Normaler Benutzer
Beiträge: 7
Registriert: Sa 15. Jul 2006, 21:41

Beitrag von dl1dwl »

Hallo Ronny,
danke für Deine Antwort. Die Beschreibung im FA ist mir bekannt.Aber ich glaube das Problem liegt an einer anderen Stelle. Ich werde Dir mal genau beschreiben was ich probiert habe.

USB-Port(COM8)---Loopsteuerung COM8 Frequenzanzeige funktioniert

MixW CAT-Port(COM8) kann nicht geöffnet
werden, wird bereits benutzt

Wird MixW zuerst gestartet,funktioniert MixW aber die Loopsteuerung gibt an das der Port 8 belegt ist. Das ist normal,denn 2 Programme auf einen Port geht nicht

VSPE Funktion Splitter COM8 auf COM3
- MixW auf COM3---Frequenzsteuerung des TRX geht nicht,aber Sende/Empfangsumschaltung funktioniert
- Loopsteuerung auf COM3---Frequenz wird nicht ins Programm
übertragen

Vielleicht mache ich auch einen Denkfehler,aber der Witz ist ,dass alles schon einmal funktioniert hat.

73 de Manfred
db6zh
Normaler Benutzer
Beiträge: 1787
Registriert: Di 9. Jun 2009, 12:30

Beitrag von db6zh »

Kann es sein, daß irgendwo ein "Duplex"-Parameter fehlt ?? 73 Peter (der nur COM Protokolle, aber nicht die Appl. kennt)
dm6dx
Normaler Benutzer
Beiträge: 314
Registriert: So 18. Feb 2007, 16:22
Wohnort: Berlin

Beitrag von dm6dx »

Das ist normal,denn 2 Programme auf einen Port geht nicht
richtig :wink:

Ich kenne dieses VSPE nicht....
...wir versuchen es mal ohne.

Loop Steuerung???
http://www.qsl.net/hb9mtn/loopcontrol.pdf
...diese?

Starte doch einfach MixW und ändere den Port in der Systemsteuerung, danach startest du Loop und arbeitest mit Port 8.

73 de Robby
dl1dwl
Normaler Benutzer
Beiträge: 7
Registriert: Sa 15. Jul 2006, 21:41

Beitrag von dl1dwl »

Hallo Robby,hallo Peter,
ich wüßte nicht wo ich nach den genannten Duplex-Parametern suchen sollte.

Ich benutze eine andere Software.Von HB9MTN die Software hatte ich zuerst genommen.
Leider funktioniert Dein Vorschlag nicht.
MixW muß auf dem gleichen USB-Serial-Port wie das USB-Interface laufen. Sonst kommt bei MixW (Hardware - Cat-Einstellung) die Fehlermeldung Port ist belegt oder existiert nicht.
Für die Loopsteuerung ist natürlich o.g. Port belegt und auf jedem anderen Port erfolgt keine Frequenzübergabe.
Es kann das Problem nur mit VSPE oder einer ähnlichen Software gelöst werden.Mit com0com habe ich auch schon getestet, aber ohne Erfolg.

73 de Manfred
Antworten